<!DOCTYPE html><html lang="en-US" prefix="og: https://ogp.me/ns#"><head><meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,d,_,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),z=parseInt(__ez.dot.getTargeting(t,"compid")),g=0,c=0,l=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(l)&&(void 0!==l.creative_id&&(c=l.creative_id),void 0!==l.line_item_id&&(g=l.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:d,est_revenue:_,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:z,line_item_id:g,creative_id:c,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),d=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));(void 0!==window.isAmp&&isAmp||void 0!==window.ezWp&&ezWp)&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(d+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(d)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,d){var _=e.split("/");if(__ez.dot.isDefined(e)&&3===_.length&&__ez.dot.isValid(t)){var n=_[0],r={type:"impression",impression_id:_[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==d&&(r.revenue=d),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-2&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-2&cb=5', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-2&cb=7', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="https://www.hydrogenfuelnews.com/xmlrpc.php" />

<meta property="og:title" content="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient" />
<meta property="og:description" content="The zero-emissions technology’s efficiency has been rated by an independent third-party firm. The Jericho Energy Ventures Inc. zero-emission hydrogen boiler" />
<meta property="og:url" content="https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/" />
<meta property="og:image:alt" content="Hydrogen boiler - 100% Efficiency" />
<meta property="og:image" content="http://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:type" content="article" />
<meta property="og:article:published_time" content="2022-10-21 03:00:35" />
<meta property="og:article:modified_time" content="2022-10-21 06:09:38" />
<meta property="og:article:tag" content="clean energy" />
<meta property="og:article:tag" content="hydrogen boiler technology" />
<meta property="og:article:tag" content="Hydrogen energy technology" />
<meta property="og:article:tag" content="hydrogen technologies" />
<meta property="og:article:tag" content="Jericho hydrogen boiler" />
<meta property="og:article:tag" content="Process Engineering Associates" />
<meta property="og:article:tag" content="zero-emission Dynamic Combustion Chamber" />
<meta property="og:article:tag" content="zero-emission energy" />


<meta name="twitter:card" content="summary" />
<meta name="twitter:title" content="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient" />
<meta name="twitter:description" content="The zero-emissions technology’s efficiency has been rated by an independent third-party firm. The Jericho Energy Ventures Inc. zero-emission hydrogen boiler" />
<meta name="twitter:image" content="http://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg" />
<meta name="twitter:image:alt" content="Hydrogen boiler - 100% Efficiency" />

<meta name="author" content="Tami Hood" />

<title>Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient - H2 News</title>
<meta name="description" content="The Jericho Energy Ventures Inc. zero-emission hydrogen boiler has been rated as nearly 100 percent fuel efficient by an independent third-party" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient - H2 News" />
<meta property="og:description" content="The Jericho Energy Ventures Inc. zero-emission hydrogen boiler has been rated as nearly 100 percent fuel efficient by an independent third-party" />
<meta property="og:url" content="https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/" />
<meta property="og:site_name" content="Hydrogen Fuel News" />
<meta property="article:publisher" content="https://www.facebook.com/HydrogenFuelNews/" />
<meta property="article:tag" content="clean energy" />
<meta property="article:tag" content="hydrogen boiler technology" />
<meta property="article:tag" content="Hydrogen energy technology" />
<meta property="article:tag" content="hydrogen technologies" />
<meta property="article:tag" content="Jericho hydrogen boiler" />
<meta property="article:tag" content="Process Engineering Associates" />
<meta property="article:tag" content="zero-emission Dynamic Combustion Chamber" />
<meta property="article:tag" content="zero-emission energy" />
<meta property="article:section" content="Hydrogen companies" />
<meta property="og:updated_time" content="2022-10-21T06:09:38-07:00" />
<meta property="og:image" content="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg" />
<meta property="og:image:secure_url" content="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="og:image:alt" content="Hydrogen boiler - 100% Efficiency" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="article:published_time" content="2022-10-21T03:00:35-07:00" />
<meta property="article:modified_time" content="2022-10-21T06:09:38-07:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient - H2 News" />
<meta name="twitter:description" content="The Jericho Energy Ventures Inc. zero-emission hydrogen boiler has been rated as nearly 100 percent fuel efficient by an independent third-party" />
<meta name="twitter:site" content="@hydrogenfuelnew" />
<meta name="twitter:creator" content="@hydrogenfuelnew" />
<meta name="twitter:image" content="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Tami Hood" />
<meta name="twitter:label2" content="Time to read" />
<meta name="twitter:data2" content="1 minute" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.hydrogenfuelnews.com/#organization","name":"Hydrogen Fuel News","logo":{"@type":"ImageObject","@id":"https://www.hydrogenfuelnews.com/#logo","url":"http://www.hydrogenfuelnews.com/wp-content/uploads/2021/01/cropped-hydrogen-fuel-cell.png","contentUrl":"http://www.hydrogenfuelnews.com/wp-content/uploads/2021/01/cropped-hydrogen-fuel-cell.png","caption":"Hydrogen Fuel News","inLanguage":"en-US","width":"512","height":"512"}},{"@type":"WebSite","@id":"https://www.hydrogenfuelnews.com/#website","url":"https://www.hydrogenfuelnews.com","name":"Hydrogen Fuel News","publisher":{"@id":"https://www.hydrogenfuelnews.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg","url":"https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg","width":"1200","height":"800","caption":"Hydrogen boiler - 100% Efficiency","inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/#webpage","url":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/","name":"Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient - H2 News","datePublished":"2022-10-21T03:00:35-07:00","dateModified":"2022-10-21T06:09:38-07:00","isPartOf":{"@id":"https://www.hydrogenfuelnews.com/#website"},"primaryImageOfPage":{"@id":"https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg"},"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.hydrogenfuelnews.com/author/tami-2-2-2/","name":"Tami Hood","url":"https://www.hydrogenfuelnews.com/author/tami-2-2-2/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/ddef45ff246c316efa43b4c90f9a24c7?s=96&amp;d=blank&amp;r=g","url":"https://secure.gravatar.com/avatar/ddef45ff246c316efa43b4c90f9a24c7?s=96&amp;d=blank&amp;r=g","caption":"Tami Hood","inLanguage":"en-US"},"worksFor":{"@id":"https://www.hydrogenfuelnews.com/#organization"}},{"@type":"NewsArticle","headline":"Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient","keywords":"Hydrogen boiler,Jericho Energy Ventures,H2 boiler,zero-emission hydrogen boilers,clean energy sources","datePublished":"2022-10-21T03:00:35-07:00","dateModified":"2022-10-21T06:09:38-07:00","articleSection":"Hydrogen companies, Hydrogen Fuel Cell, Hydrogen news, Renewable Energy News","author":{"@id":"https://www.hydrogenfuelnews.com/author/tami-2-2-2/"},"publisher":{"@id":"https://www.hydrogenfuelnews.com/#organization"},"description":"The Jericho Energy Ventures Inc. zero-emission hydrogen boiler has been rated as nearly 100 percent fuel efficient by an independent third-party firm.","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.hydrogenfuelnews.com/#organization"},"name":"Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient","@id":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/#richSnippet","isPartOf":{"@id":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/#webpage"},"image":{"@id":"https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/#webpage"}}]}</script>

<link rel="dns-prefetch" href="//analytics.aweber.com" />
<link rel="stylesheet" id="wp-block-library-css" href="//www.hydrogenfuelnews.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.3" type="text/css" media="all" />
<style id="global-styles-inline-css" type="text/css">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</style>
<link rel="stylesheet" id="bootstrap-css" href="//www.hydrogenfuelnews.com/wp-content/themes/envo-magazine/css/bootstrap.css?ver=3.3.7" type="text/css" media="all" />
<link rel="stylesheet" id="envo-magazine-stylesheet-css" href="//www.hydrogenfuelnews.com/wp-content/themes/envo-magazine/style.css?ver=1.3.12" type="text/css" media="all" />
<link rel="stylesheet" id="font-awesome-css" href="//www.hydrogenfuelnews.com/wp-content/themes/envo-magazine/css/font-awesome.min.css?ver=4.7.0" type="text/css" media="all" />
<script type="text/javascript" src="//analytics.aweber.com/js/awt_analytics.js?id=1jpsU" id="script-js"></script>
<script type="text/javascript" src="//www.hydrogenfuelnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script>
<link rel="https://api.w.org/" href="https://www.hydrogenfuelnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.hydrogenfuelnews.com/wp-json/wp/v2/posts/55584" /><link rel="alternate" type="application/json+oembed" href="https://www.hydrogenfuelnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.hydrogenfuelnews.com%2Fhydrogen-boiler-jericho%2F8555584%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.hydrogenfuelnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.hydrogenfuelnews.com%2Fhydrogen-boiler-jericho%2F8555584%2F&amp;format=xml" />

<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-41953488-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41953488-1');
</script>
<meta name="google-site-verification" content="BNSDnskhzqQMGtxGipC79GG_OoYSMTfQVfATxzuCDCk" />
<meta name="google-site-verification" content="3aKKf8ye7FYN-4GvZVkOBcUNx2jjlgFiyUuiX9-Lmaw" />
<script type="text/javascript" src="//analytics.aweber.com/js/awt_analytics.js?id=1jpsU"></script>
<script data-ad-client="ca-pub-5393409700595942" async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="yandex-verification" content="7bc772cf39b1684a" />

<script async="" src="https://www.googletagmanager.com/gtag/js?id=AW-1011707975"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'AW-1011707975');
</script>
<style type="text/css" id="envo-magazine-header-css">
			.site-header {
			background-image: url(https://www.hydrogenfuelnews.com/wp-content/uploads/2021/12/cropped-hydrogen-news-renewable-energy-news-scaled-1.jpg);
			background-repeat: no-repeat;
			background-position: 50% 50%;
			-webkit-background-size: cover;
			-moz-background-size:    cover;
			-o-background-size:      cover;
			background-size:         cover;
		}
		.site-title a, .site-title, .site-description {
			color: #ffffff;
		}
			
	</style>
<link rel="icon" href="https://www.hydrogenfuelnews.com/wp-content/uploads/2021/01/cropped-hydrogen-fuel-cell-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.hydrogenfuelnews.com/wp-content/uploads/2021/01/cropped-hydrogen-fuel-cell-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.hydrogenfuelnews.com/wp-content/uploads/2021/01/cropped-hydrogen-fuel-cell-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.hydrogenfuelnews.com/wp-content/uploads/2021/01/cropped-hydrogen-fuel-cell-270x270.png" />
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 278980;
var ezdomain = 'hydrogenfuelnews.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":278980,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"3490b816-75fb-499d-564f-c3184ca07b51","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":67128,"response_time_orig":4,"serverid":"3.236.221.171:7693","state":"VA","t_epoch":1666420396,"template_id":126,"time_on_site_visit":0,"url":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/","user_id":0,"word_count":786,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_278980=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["3490b816-75fb-499d-564f-c3184ca07b51", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script>
<link rel="preload stylesheet" type="text/css" href="/ezvideo/ezvideojscss.css?cb=45" as="style">
<link rel="stylesheet" type="text/css" href="/ezvideo/ezvideojspluginscss.css?cb=45">
<style>.video-container{overflow:hidden!important}.player-container{background:#1a1a1a!important;overflow:auto!important;width:900px!important;margin:0 0 20px!important}.ez-video-container{display:-webkit-box;display:-moz-box;display:-ms-flexbox;display:-webkit-flex;display:flex;flex-wrap:wrap}@media screen and (min-width:100px){.ez-video-container.ez-stuck{position:fixed;bottom:120px;z-index:999;right:20px;width:60%;height:auto;transform:translateY(100%);animation:fade-in-up .25s ease forwards}}@media screen and (min-width:768px){.ez-video-container.ez-stuck{position:fixed;bottom:120px;z-index:999;right:20px;width:40%;height:auto;transform:translateY(100%);animation:fade-in-up .25s ease forwards}}@media screen and (min-width:1024px){.ez-video-container.ez-stuck{position:fixed;bottom:120px;z-index:999;right:20px;margin-bottom:20px;width:20%;height:auto;transform:translateY(100%);animation:fade-in-up .75s ease forwards}}.ez-video-container.ez-stuck.vertical{width:175px;height:310px}.ez-video-container.ez-stuck.ez-float-left{right:auto;left:20px}.ez-video-container.ez-stuck.ez-float-center{right:auto;left:50%;margin-left:-130px}.ez-video-container.ez-stuck.ez-float-center.vertical{margin-left:-80px}.ez-video-ad-container{top:0;position:absolute;display:none;width:100%;height:100%}.ez-vad-controls{bottom:0;height:1.4em;position:absolute;overflow:hidden;display:none;opacity:1;background-color:#07141eb2;background:-moz-linear-gradient( bottom,rgba(7,20,30,.7) 0%,rgba(7,20,30,0) 100%);background:-webkit-gradient( linear,left bottom,left top,color-stop(0%,rgba(7,20,30,.7)),color-stop(100%,rgba(7,20,30,0)));background:-webkit-linear-gradient( bottom,rgba(7,20,30,.7) 0%,rgba(7,20,30,0) 100%);background:-o-linear-gradient(bottom,rgba(7,20,30,.7) 0%,rgba(7,20,30,0) 100%);background:-ms-linear-gradient(bottom,rgba(7,20,30,.7) 0%,rgba(7,20,30,0) 100%);background:linear-gradient(to top,rgba(7,20,30,.7) 0%,rgba(7,20,30,0) 100%);filter:progid:DXImageTransform.Microsoft.gradient( startColorstr='#0007141E',endColorstr='#07141E',GradientType=0 )}.ez-vad-controls.ez-vad-controls-showing{height:3.7em}.ez-vad-countdown{height:1em;color:#fff;text-shadow:0 0 .2em #000;cursor:default}.ez-vad-seek-bar{top:1.2em;height:.3em;position:absolute;background:#fff6}.ez-vad-progress{width:0;height:.3em;background-color:#ecc546}.ez-vad-play-pause,.ez-vad-mute,.ez-vad-slider,.ez-vad-fullscreen{width:2.33em;height:1.33em;top:.733em;left:0;position:absolute;color:#ccc;font-size:1.5em;line-height:2;text-align:center;font-family:VideoJS;cursor:pointer}.ez-vad-mute{left:auto;right:5.667em}.ez-vad-slider{left:auto;right:2.33em;width:3.33em;height:.667em;top:1.33em;background-color:#555}.ez-vad-slider-level{width:100%;height:.667em;background-color:#ecc546}.ez-vad-fullscreen{left:auto;right:0}.ez-vad-playing:before{content:"\00f103"}.ez-vad-paused:before{content:"\00f101"}.ez-vad-playing:hover:before,.ez-vad-paused:hover:before{text-shadow:0 0 1em #fff}.ez-vad-non-muted:before{content:"\00f107"}.ez-vad-muted:before{content:"\00f104"}.ez-vad-non-muted:hover:before,.ez-vad-muted:hover:before{text-shadow:0 0 1em #fff}.ez-vad-non-fullscreened:before{content:"\00f108"}.ez-vad-fullscreened:before{content:"\00f109"}.ez-vad-non-fullscreened:hover:before,.ez-vad-fullscreened:hover:before{text-shadow:0 0 1em #fff}.ez-video-wrap video{visibility:visible!important}.ez-wrap-float-only{height:0!important;width:0!important}.ez-playlist-float-only{display:none!important}.video-js .vjs-share__middle{padding:0 0!important;width:80%}.video-js{float:left!important;font-size:10px;color:#fff;position:relative!important;width:100%;height:auto;margin:0}@keyframes fade-in-up{0%{opacity:0}100%{transform:translateY(0);opacity:1}}.floating-placeholder{background-color:#000;display:block}.floating-placeholder-sizer{width:100%;padding-bottom:56.25%}.ez-video-wrap{text-align:center;clear:both}.vjs-playlist{height:114px}.ez-video-link{margin-top:0px;margin-bottom:0px;margin-left:0px;margin-right:0px;font-size:16px;white-space:nowrap;overflow:hidden;text-overflow:ellipsis;display:block!important;text-align:center;max-width:90vw}</style>
<link rel="stylesheet" type="text/css" href="/ezvideo/ezvideocss.css?cb=45">
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "VideoObject",
  "potentialAction": {
    "@type": "SeekToAction",
    "target": "https://hydrogenfuelnews.com/ezoic/video/embed_humix.go?contentId=9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2\u0026t={seek_to_second_number}",
    "startOffset-input": "required name=seek_to_second_number"
  },
  "name": "Hydrogen tech developer to build fastest electrocatalyst discovery process",
  "description": "[Hydrogen News](https://www.hydrogenfuelnews.com) H2U Technologies closed $11 million in Series A funding and will use the proceeds to achieve its goal...\n\nJericho Energy Ventures videos: \nhttps://www.youtube.com/watch?v=IxQRMLQXhxQ\nhttps://www.youtube.com/watch?v=iBo9FrxxPF4\n\nLearn more about green hydrogen: https://www.hydrogenfuelnews.com/what-is-green-hydrogen/\nGrab our free hydrogen ebook here: https://www.hydrogenfuelnews.com/hydrogen-fuel-cell-ebook/\n\n#H2UTechnologies #JerichoEnergyVentures #H2UTechnologiesCDE #Caltech #FreeflowVentures #greenhydrogen #greenhydrogentechnology #H2U #H2Uhydrogentechnologies #H2Uhydrogentechnologydevelopment #HessCorporation  #proprietaryhydrogentechnology #VoLoEarthVentures",
  "thumbnailUrl": "https://video-streaming.ezoic.com/poster/OZoAcQkYYLhaMTel/9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2_pWKAPR.jpg",
  "uploadDate": "2022-03-02T17:37:01+00:00",
  "duration": "T0H2M28S",
  "contentUrl": "https://video-streaming.ezoic.com/a8f8eb4bd1c479ce00682770852fd082/out/v1/a2c27c92de4a42999e506878d5216b07/89dff34a573c46819be264c12b9b0b84/9b8950cd2baa424d97755a15151ed2af/index.m3u8",
  "embedUrl": "https://hydrogenfuelnews.com/ezoic/video/embed.go?contentId=9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2"
}
</script>
<script>window.ezVideo = {"appendFloatAfterAd":false,"language":"en-u-rg-uszzzz","titleString":"➡️PLAY THIS HYDROGEN NEWS ARTICLE","titleOption":"4"}</script></head>
<body id="blog" class="post-template-default single single-post postid-55584 single-format-standard wp-custom-logo">
<a class="skip-link screen-reader-text" href="#site-content">Skip to the content</a><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627"></feFuncR><feFuncG type="table" tableValues="0 0.49803921568627"></feFuncG><feFuncB type="table" tableValues="0 0.49803921568627"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1"></feFuncR><feFuncG type="table" tableValues="0 1"></feFuncG><feFuncB type="table" tableValues="0 1"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765"></feFuncR><feFuncG type="table" tableValues="0 1"></feFuncG><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1"></feFuncR><feFuncG type="table" tableValues="0 0.27843137254902"></feFuncG><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0"></feFuncR><feFuncG type="table" tableValues="0 0.64705882352941"></feFuncG><feFuncB type="table" tableValues="0 1"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1"></feFuncR><feFuncG type="table" tableValues="0 0.94901960784314"></feFuncG><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745"></feFuncR><feFuncG type="table" tableValues="0 1"></feFuncG><feFuncB type="table" tableValues="0.44705882352941 0.4"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1"></feFuncR><feFuncG type="table" tableValues="0 0.66274509803922"></feFuncG><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg> <div class="site-header container-fluid">
<div class="container">
<div class="row">
<div class="site-heading ">
<div class="site-branding-logo">
<a href="https://www.hydrogenfuelnews.com/" class="custom-logo-link" rel="home"><img width="200" height="60" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2021/11/cropped-Hydrogen-news-3.png" class="custom-logo" alt="hydrogen news" /></a> </div>
<div class="site-branding-text">
<p class="site-title"><a href="https://www.hydrogenfuelnews.com/" rel="home">Hydrogen Fuel News</a></p>
<p class="site-description">
Hydrogen News – Green Hydrogen </p>
</div>
</div>
</div>
</div>
</div>
<div class="main-menu">
<nav id="site-navigation" class="navbar navbar-default">
<div class="container">
<div class="navbar-header">
<button id="main-menu-panel" class="open-panel visible-xs" data-panel="main-menu-panel">
<span></span>
<span></span>
<span></span>
</button>
</div>
<ul class="nav navbar-nav search-icon navbar-left hidden-xs">
<li class="home-icon">
<a href="https://www.hydrogenfuelnews.com/" title="Hydrogen Fuel News">
<i class="fa fa-home"></i>
</a>
</li>
</ul>
<div class="menu-container"><ul id="menu-nav-menu" class="nav navbar-nav navbar-left"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-30855" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-30855"><a title="Hydrogen news" href="https://www.hydrogenfuelnews.com/featured-news/">Hydrogen news</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-48485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48485"><a title="Free ebook" href="https://www.hydrogenfuelnews.com/hydrogen-fuel-cell-ebook/">Free ebook</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-30838" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30838"><a title="Submit Press Release" href="https://www.hydrogenfuelnews.com/submit-press-release/">Submit Press Release</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-49271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49271"><a title="Green Hydrogen" href="https://www.hydrogenfuelnews.com/what-is-green-hydrogen/">Green Hydrogen</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-45295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-45295 dropdown"><a title="H2 Learning" href="https://www.hydrogenfuelnews.com/how-is-hydrogen-fuel-made/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">H2 Learning <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-35153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35153"><a title="How Do Hydrogen Fuel Cells Work" href="https://www.hydrogenfuelnews.com/alternative-energy/how-does-hydrogen-fuel-cells-work/">How Do Hydrogen Fuel Cells Work</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-50770" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50770"><a title="Job Market" href="https://www.hydrogenfuelnews.com/alternative-energy-jobs/">Job Market</a></li>
</ul></div> <ul class="nav navbar-nav search-icon navbar-right hidden-xs">
<li class="top-search-icon">
<a href="#">
<i class="fa fa-search"></i>
</a>
</li>
<div class="top-search-box">
<form role="search" method="get" id="searchform" class="searchform" action="https://www.hydrogenfuelnews.com/">
<div>
<label class="screen-reader-text" for="s">Search for:</label>
<input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form> </div>
</ul>
</div>
</nav>
</div>
<div id="site-content" class="container main-container" role="main">
<div class="page-area">


<div class="row">
<article class="col-md-8">
<div class="post-55584 post type-post status-publish format-standard has-post-thumbnail hentry category-hydrogen-companies category-hydrogen-fuel-cell category-featured-news category-alternative-energy tag-clean-energy tag-hydrogen-boiler-technology tag-hydrogen-energy-technology tag-hydrogen-technologies tag-jericho-hydrogen-boiler tag-process-engineering-associates tag-zero-emission-dynamic-combustion-chamber tag-zero-emission-energy">
<div class="news-thumb ">
<img src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-100-Efficiency-1140x641.jpg" title="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient" alt="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient" />
</div>
<h1 class="single-title">Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient</h1><span id="ezoic-pub-video-placeholder-12" class="ezoic-videopicker-video"></span> <span class="posted-date">
October 21, 2022	</span>
<span class="comments-meta">
<a href="https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/#comments" rel="nofollow" title="Comment on Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient">
0 </a>
<i class="fa fa-comments-o"></i>
</span>
<span class="author-meta">
<span class="author-meta-by">By</span>
<a href="https://www.hydrogenfuelnews.com/author/tami-2-2-2/">
Tami Hood </a>
</span>
<div class="single-content">
<div class="single-entry-summary">
<h2>The zero-emissions technology’s efficiency has been rated by an independent third-party firm.</h2>
<p><span style="font-size: 14pt;">The Jericho Energy Ventures Inc. zero-emission hydrogen boiler has been rated as nearly 100 percent fuel efficient by an independent third-party firm.</span></p><div id="ezoic-pub-ad-placeholder-170" data-inserter-version="2"></div>
<h3>Process Engineering Associates LLC tested the zero-emission Dynamic Combustion Chamber.<a href="https://www.hydrogenfuelnews.com/submit-press-release/" target="_blank" rel="nofollow noopener"><img class="alignright size-full wp-image-55556" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/hydrogen-news-press-release-1.gif" alt="hydrogen news press release" width="325" height="285" title="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient 1" /></a></h3>
<p><span style="font-size: 14pt;">“All off-gas samples taken during the test did not detect hydrogen in the sample,” said Process Engineering Associates senior process engineer Chris Muntean. “This data suggests that the burners are combusting the vast majority (or all) of the H2 (hydrogen) gas being supplied to the <a title="How does a hydrogen boiler work?" href="https://www.hydrogenfuelnews.com/how-do-hydrogen-boilers-work/8552129/">boiler.</a> Based on these performance results, little to no fuel is left unburned.”</span><span id="ezoic-pub-video-placeholder-11" class="ezoic-videopicker-video"></span></p>
<p><span id="ezoic-pub-video-placeholder-3" class="ezoic-videopicker-video"></span><div id="ez-video-wrap-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="ez-video-wrap" style="align-self: stretch;margin-top: 0px !important;margin-bottom: 0px !important;"><div style="max-width:640px;" class="ez-video-center"><div id="floating-placeholder-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="floating-placeholder" style="display: none;"><div id="floating-placeholder-sizer-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="floating-placeholder-sizer"></div></div><div id="ez-video-container-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="ez-video-container ez-float-right" style="flex-wrap: wrap;"><div class="ez-video-ez-stuck-bar" id="ez-video-ez-stuck-bar"><div class="ez-video-ez-stuck-title" id="ez-video-stuck-title-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2">Hydrogen tech developer to build fa...</div><div class="ez-video-ez-stuck-close vjs-icon-cancel" id="ez-video-ez-stuck-close" onclick="document.getElementById(&#39;ezmobfooter&#39;).style.display=&#39;none&#39;;"><span class="vjs-icon-placeholder"></span></div></div><video id="ez-video-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="video-js vjs-16-9 ez-vid-placeholder" controls="" preload="metadata"><p class="vjs-no-js">Please enable JavaScript</p></video><div id="lds-ring-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="lds-ring"><div></div><div></div><div></div><div></div></div><div id="ez-video-links-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" style="position:absolute;"></div></div><a id="ez-video-link-9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" class="ez-video-link" href="/humix/video/9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2" target="_self">➡️PLAY THIS HYDROGEN NEWS ARTICLE</a></div></div><span style="font-size: 14pt;">As companies and organizations take steps toward cleaner sources of energy and electricity to achieve their <a title="Industrial hydrogen applications must replace fossil fuels for climate targets, report" href="https://www.hydrogenfuelnews.com/industrial-hydrogen-applications-must-replace-fossil-fuels-for-climate-targets-report/8539624/">climate targets</a>, Jericho is hopeful that its hydrogen boiler technology will appeal for purposes such as hot water, commercial heating, and industrial steam boilers.</span></p><div id="ezoic-pub-ad-placeholder-178" data-inserter-version="2"></div>
<p><img loading="lazy" class="aligncenter wp-image-55581 size-full" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-Climate-Target.jpg" alt="Hydrogen boiler - Climate Target" width="1200" height="800" srcset="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-Climate-Target.jpg 1200w, https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-Climate-Target-300x200.jpg 300w, https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-Climate-Target-825x550.jpg 825w, https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-boiler-Climate-Target-768x512.jpg 768w" sizes="(max-width: 1200px) 100vw, 1200px" title="Jericho Energy Ventures hydrogen boiler rated almost 100 percent efficient 2" /></p>
<p><span style="font-size: 14pt;">Hydrogen Technologies is a fully owned Jericho subsidiaries. The company has patented its H2 and oxygen burning method within a vacuum chamber to produce high-temperature water and steam without also emitting greenhouse gases or other types of pollutant.</span></p>
<h3>The only byproduct produced by the hydrogen boiler is water, and that is recycled by the technology.</h3>
<p><span style="font-size: 14pt;">The technology is meant to replace traditional existing boilers that currently burn natural gas, diesel, fuel oil, or even coal.</span></p><div class="AW-Form-497551345"></div>
<script type="text/javascript">(function(d,s,id) {
                    var js;
                    var fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id)) return; js = d.createElement(s);
                    js.id = id; js.src = "https://forms.aweber.com/form/45/497551345.js";
                    fjs.parentNode.insertBefore(js, fjs);
                    }(document, "script", "aweber-wjs-2100090170"));
                </script><p></p><div id="ezoic-pub-ad-placeholder-179" data-inserter-version="2"></div>
<p><span style="font-size: 14pt;">“Our system is more efficient than traditional steam systems,” said Brian Williamson, Jericho CEO, as quoted in a recent <a title="Third-Party Firm Rates Hydrogen Boiler Nearly 100% Efficient" href="https://www.streetwisereports.com/article/2022/10/17/third-party-firm-rates-hydrogen-boiler-nearly-100-efficient.html" target="_blank" rel="nofollow noopener">Streetwise Reports</a>. “They did a whole battery of tests on our system and validated that it is, in fact, 95% cost-efficient, which is . . . 20% plus more efficient than anything else that’s out there in the market in conventional fossil fuels. There’s also 100% hydrogen burn in the system, meaning that there’s no waste.”</span></p>
<p><span style="font-size: 14pt;">The test the hydrogen boiler underwent supports the findings Jericho has conducted on the technology itself. The company is seeking to use the data from the third-party company to draw customers and investors. They held a demonstration of the technology at the end of last month in Modesto, California, for potential commercial and industrial clients. According to <a title="Hydrogen Technologies" href="https://hydrogentechnologiesinc.com/#vision" target="_blank" rel="noopener">Hydrogen Technologies</a>, the demonstration was successful to the point that it now plans to hold a demo week from November 14-18.</span></p>
</div>
<div class="entry-footer"><div class="cat-links"><span class="space-right">Category</span><a href="https://www.hydrogenfuelnews.com/hydrogen-companies/">Hydrogen companies</a> <a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-cell/">Hydrogen Fuel Cell</a> <a href="https://www.hydrogenfuelnews.com/featured-news/">Hydrogen news</a> <a href="https://www.hydrogenfuelnews.com/alternative-energy/">Renewable Energy News</a></div></div> <div class="entry-footer"><div class="tags-links"><span class="space-right">Tags</span><a href="https://www.hydrogenfuelnews.com/tag/clean-energy/">clean energy</a> <a href="https://www.hydrogenfuelnews.com/tag/hydrogen-boiler-technology/">hydrogen boiler technology</a> <a href="https://www.hydrogenfuelnews.com/tag/hydrogen-energy-technology/">Hydrogen energy technology</a> <a href="https://www.hydrogenfuelnews.com/tag/hydrogen-technologies/">hydrogen technologies</a> <a href="https://www.hydrogenfuelnews.com/tag/jericho-hydrogen-boiler/">Jericho hydrogen boiler</a> <a href="https://www.hydrogenfuelnews.com/tag/process-engineering-associates/">Process Engineering Associates</a> <a href="https://www.hydrogenfuelnews.com/tag/zero-emission-dynamic-combustion-chamber/">zero-emission Dynamic Combustion Chamber</a> <a href="https://www.hydrogenfuelnews.com/tag/zero-emission-energy/">zero-emission energy</a></div></div> </div>
<div class="prev-next-links">
<div class="arrowLeft">
<a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-eu-future/8555577/" rel="prev"><i class="fa fa-angle-double-left fa-2x" aria-hidden="true"></i></a> <div class="prev-next-links-thumb">
<a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-eu-future/8555577/" rel="prev"><img width="160" height="120" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/Hydrogen-fuel-EU-Future-Road-160x120.jpg" class="attachment-envo-magazine-thumbnail size-envo-magazine-thumbnail wp-post-image" alt="Hydrogen fuel - EU - Future - Road" loading="lazy" title="Cyprus Energy Regulatory Authority says hydrogen fuel is vital to EU’s future 3" /></a> </div>
<div class="prev-next-links-title">
<a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-eu-future/8555577/" rel="prev">Cyprus Energy Regulatory Authority says hydrogen fuel is vital to EU’s future</a> </div>
</div>
</div>
<div class="single-footer">
<div id="comments" class="comments-template">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/hydrogen-boiler-jericho/8555584/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.hydrogenfuelnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type="hidden" name="comment_post_ID" value="55584" id="comment_post_ID" />
<input type="hidden" name="comment_parent" id="comment_parent" value="0" />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e929e67e66" /></p> <p>
<input value="1" id="aweber_checkbox" type="checkbox" style="width:inherit;" name="aweber_signup_checkbox" />
<label for="aweber_checkbox">
Sign up to our newsletter! </label>
</p>
<br />
<p style="display: none !important;"><label>Δ<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="21" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p> </div>
</div>
</div>
</article>
<aside id="sidebar" class="col-md-4">
<div id="custom_html-26" class="widget_text widget widget_custom_html"><div class="widget-title"><h3>Follow Us…</h3></div><div class="textwidget custom-html-widget"><a href="https://www.tiktok.com/@hydrogenfuelnews" target="_blank" rel="nofollow noopener"><img class="alignleft wp-image-52226 size-full" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/04/hydrogenfuelnews.jpg" alt="TikTok Hydrogenfuelnews" width="40" height="40" /></a><a href="https://www.instagram.com/hydrogenfuelnews/" target="_blank" rel="nofollow noopener"><img class="alignleft wp-image-51220" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/01/Instagram-Hydrogen-News.jpg" alt="Hydrogen news instagram channel" width="40" height="40" /></a><a href="https://www.linkedin.com/in/hydrogenfuelnews/" target="_blank" rel="nofollow noopener"><img class="alignleft wp-image-50977" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/01/linkedin-hydrogen-news.jpg" alt="linkedin hydrogen news" width="40" height="40" /></a> <a href="https://www.youtube.com/c/hydrogennews" target="_blank" rel="nofollow noopener"><img class="alignleft wp-image-50978" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/01/youtube-hydrogen-news.jpg" alt="youtube hydrogen news" width="40" height="40" /></a><a href="https://twitter.com/hydrogenfuelnew" target="_blank" rel="nofollow noopener"><img class="alignleft wp-image-50976" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/01/twitter-hydrogen-news.jpg" alt="twitter hydrogenfuelnews" width="40" height="40" /></a><a href="https://www.facebook.com/HydrogenFuelNews/" target="_blank" rel="nofollow noopener"><img class="alignleft wp-image-50975" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/01/Facebook-Hydrogen-News.jpg" alt="Facebook Hydrogen Fuel Cell Like" width="40" height="40" /></a></div></div><div id="custom_html-39" class="widget_text widget widget_custom_html"><div class="widget-title"><h3>Shop imogix.com➡️This week 15% Off Hydrogen Gear with code: H2coupon</h3></div><div class="textwidget custom-html-widget"><a href="https://www.imogix.com/collections/science-wear/products/i-believe-in-hydrogen-short-sleeve-unisex-t-shirt" target="_blank" rel="nofollow noopener"><img class="aligncenter wp-image-55357 size-full" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/10/h2-gear1.gif" alt="hydrogen tshirt for sale" width="400" height="400" /></a></div></div><div id="media_image-8" class="widget widget_media_image"><div class="widget-title"><h3>New Green Jobs Listed</h3></div><a href="https://www.hydrogenfuelnews.com/alternative-energy-jobs/" rel="no follow noopener" target="_blank"><img width="450" height="400" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/06/looking-for-a-job-450-×-400-px.jpg" class="image wp-image-53318  attachment-full size-full" alt="Green Jobs Listed Here" loading="lazy" style="max-width: 100%; height: auto;" title="New Green Jobs Listed" srcset="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/06/looking-for-a-job-450-×-400-px.jpg 450w, https://www.hydrogenfuelnews.com/wp-content/uploads/2022/06/looking-for-a-job-450-×-400-px-300x267.jpg 300w" sizes="(max-width: 450px) 100vw, 450px" /></a></div><div id="custom_html-33" class="widget_text widget widget_custom_html"><div class="widget-title"><h3>Hydrogen Fuel News Free ebook</h3></div><div class="textwidget custom-html-widget"><a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-cell-ebook/" target="_blank" rel="follow no noopener"><img class="aligncenter wp-image-51880 size-full" title="Hydrogen News Free Ebook" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/03/hydrogen-news-download-free-ebook.jpg" alt="hydrogen fuel cell news free ebook" width="557" height="494" /></a></div></div><div id="nav_menu-9" class="widget widget_nav_menu"><div class="widget-title"><h3>Find Renewable Energy News Articles</h3></div><div class="menu-sidebar-container"><ul id="menu-sidebar" class="menu"><li id="menu-item-53153" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53153"><a href="https://www.hydrogenfuelnews.com/afc-energy-news/">AFC Energy news</a></li>
<li id="menu-item-53154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53154"><a href="https://www.hydrogenfuelnews.com/air_liquide/">Air Liquide</a></li>
<li id="menu-item-53155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53155"><a href="https://www.hydrogenfuelnews.com/ballard-power-news/">Ballard Power news</a></li>
<li id="menu-item-53156" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53156"><a href="https://www.hydrogenfuelnews.com/bloom-energy-news/">Bloom Energy News</a></li>
<li id="menu-item-53158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53158"><a href="https://www.hydrogenfuelnews.com/bp-news/">BP News</a></li>
<li id="menu-item-53160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53160"><a href="https://www.hydrogenfuelnews.com/cummins-news/">Cummins News</a></li>
<li id="menu-item-53161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53161"><a href="https://www.hydrogenfuelnews.com/doe-news/">DOE news</a></li>
<li id="menu-item-53163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53163"><a href="https://www.hydrogenfuelnews.com/doosan-news/">Doosan news</a></li>
<li id="menu-item-53165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53165"><a href="https://www.hydrogenfuelnews.com/science/">Environmental Science News</a></li>
<li id="menu-item-53166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53166"><a href="https://www.hydrogenfuelnews.com/financial/">Financial Energy News</a></li>
<li id="menu-item-53167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53167"><a href="https://www.hydrogenfuelnews.com/geothermal/">Geothermal</a></li>
<li id="menu-item-53168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53168"><a href="https://www.hydrogenfuelnews.com/green-hydrogen/">Green Hydrogen</a></li>
<li id="menu-item-53169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53169"><a href="https://www.hydrogenfuelnews.com/h2-education/">H2 Education</a></li>
<li id="menu-item-53170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53170"><a href="https://www.hydrogenfuelnews.com/hino-trucks/">Hino Trucks</a></li>
<li id="menu-item-53171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53171"><a href="https://www.hydrogenfuelnews.com/hybrid-technology/">Hybrid Technology</a></li>
<li id="menu-item-53172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53172"><a href="https://www.hydrogenfuelnews.com/hydrogen-cars/">Hydrogen Cars</a></li>
<li id="menu-item-53173" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-53173"><a href="https://www.hydrogenfuelnews.com/hydrogen-companies/">Hydrogen Companies</a></li>
<li id="menu-item-53174" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-53174"><a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-cell/">Hydrogen Fuel Cell</a></li>
<li id="menu-item-53176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53176"><a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-storage/">Hydrogen Storage</a></li>
<li id="menu-item-53177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53177"><a href="https://www.hydrogenfuelnews.com/hypoint/">Hypoint Fuel Cell News</a></li>
<li id="menu-item-53178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53178"><a href="https://www.hydrogenfuelnews.com/hyundai-news/">Hyundai news</a></li>
<li id="menu-item-53179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53179"><a href="https://www.hydrogenfuelnews.com/hyzon-motors-news/">Hyzon Motors News</a></li>
<li id="menu-item-53181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53181"><a href="https://www.hydrogenfuelnews.com/international/">International</a></li>
<li id="menu-item-53183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53183"><a href="https://www.hydrogenfuelnews.com/lifestyle-topics/">Green Lifestyle</a></li>
<li id="menu-item-53185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53185"><a href="https://www.hydrogenfuelnews.com/nikola-motors-news/">Nikola Motors News</a></li>
<li id="menu-item-53186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53186"><a href="https://www.hydrogenfuelnews.com/olympics-news/">Olympics News</a></li>
<li id="menu-item-53187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53187"><a href="https://www.hydrogenfuelnews.com/other-fuel-cell/">Other Fuel Cell</a></li>
<li id="menu-item-53188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53188"><a href="https://www.hydrogenfuelnews.com/plug-power-news/">Plug Power News</a></li>
<li id="menu-item-53189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53189"><a href="https://www.hydrogenfuelnews.com/political/">Political</a></li>
<li id="menu-item-53190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53190"><a href="https://www.hydrogenfuelnews.com/press-release/">Press Release</a></li>
<li id="menu-item-53191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53191"><a href="https://www.hydrogenfuelnews.com/renewable-energy-jobs/">Renewable Energy Jobs</a></li>
<li id="menu-item-53193" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53193"><a href="https://www.hydrogenfuelnews.com/research/">Hydrogen Research</a></li>
<li id="menu-item-53194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53194"><a href="https://www.hydrogenfuelnews.com/residential-energy/">Residential Energy</a></li>
<li id="menu-item-53195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53195"><a href="https://www.hydrogenfuelnews.com/shell-news/">Shell News</a></li>
<li id="menu-item-53196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53196"><a href="https://www.hydrogenfuelnews.com/siemens-news/">Siemens Gamesa News</a></li>
<li id="menu-item-53197" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53197"><a href="https://www.hydrogenfuelnews.com/solar-energy/">Solar Energy</a></li>
<li id="menu-item-53198" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53198"><a href="https://www.hydrogenfuelnews.com/toyota-news/">Toyota News</a></li>
<li id="menu-item-53199" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53199"><a href="https://www.hydrogenfuelnews.com/transportation/">Transportation</a></li>
<li id="menu-item-53201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53201"><a href="https://www.hydrogenfuelnews.com/waste-to-energy/">Waste to Energy</a></li>
<li id="menu-item-53202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53202"><a href="https://www.hydrogenfuelnews.com/wind-energy-2/">Wind Energy</a></li>
<li id="menu-item-54437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54437"><a href="https://www.hydrogenfuelnews.com/refund_returns/">Refund and Returns Policy</a></li>
<li id="menu-item-54441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54441"><a href="https://www.hydrogenfuelnews.com/cart/">Cart</a></li>
<li id="menu-item-54444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54444"><a href="https://www.hydrogenfuelnews.com/checkout/">Checkout</a></li>
<li id="menu-item-54447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54447"><a href="https://www.hydrogenfuelnews.com/shop/">Shop</a></li>
<li id="menu-item-54457" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54457"><a href="https://www.hydrogenfuelnews.com/store/">Store</a></li>
<li id="menu-item-55430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55430"><a href="https://www.hydrogenfuelnews.com/press-release-2/">press-release</a></li>
</ul></div></div> </aside>
</div>


</div>
</div>
<div id="content-footer-section" class="container-fluid clearfix">
<div class="container">
<div id="search-3" class="widget widget_search col-md-3"><div class="widget-title"><h3>Search Site</h3></div><form role="search" method="get" id="searchform" class="searchform" action="https://www.hydrogenfuelnews.com/">
<div>
<label class="screen-reader-text" for="s">Search for:</label>
<input type="text" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" />
</div>
</form></div><div id="custom_html-25" class="widget_text widget widget_custom_html col-md-3"><div class="widget-title"><h3>Don’t miss our free ebook…</h3></div><div class="textwidget custom-html-widget"><a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-cell-ebook/" target="_blank" rel="follow no noopener"><img class="aligncenter wp-image-51880 size-full" title="Hydrogen News Free Ebook" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/03/hydrogen-news-download-free-ebook.jpg" alt="hydrogen fuel cell news free ebook" width="557" height="494" /></a></div></div><div id="nav_menu-7" class="widget widget_nav_menu col-md-3"><div class="widget-title"><h3>Fuel News Center</h3></div><div class="menu-contact-container"><ul id="menu-contact" class="menu"><li id="menu-item-51264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51264"><a href="https://www.hydrogenfuelnews.com/contact-us/about-us/">About Us</a></li>
<li id="menu-item-52224" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52224"><a href="https://www.hydrogenfuelnews.com/contact-us/authors/">Authors</a></li>
<li id="menu-item-51263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51263"><a href="https://www.hydrogenfuelnews.com/contact-us/">Contact Us</a></li>
<li id="menu-item-51690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51690"><a href="https://www.hydrogenfuelnews.com/h2-education-donate/">Donate</a></li>
<li id="menu-item-51267" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51267"><a href="https://www.hydrogenfuelnews.com/hydrogen-fuel-cell-ebook/">Free ebook</a></li>
<li id="menu-item-51268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51268"><a href="https://www.hydrogenfuelnews.com/submit-press-release/">Submit Press Release</a></li>
<li id="menu-item-51265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51265"><a href="https://www.hydrogenfuelnews.com/welcome-to-hydrogen-fuel-news/">Welcome to Hydrogen Fuel News</a></li>
<li id="menu-item-51451" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51451"><a href="https://www.hydrogenfuelnews.com/privacy-policy/">Privacy Policy</a></li>
</ul></div></div><div id="custom_html-12" class="widget_text widget widget_custom_html col-md-3"><div class="widget-title"><h3>Energy News 24/7</h3></div><div class="textwidget custom-html-widget"><div id="newsnowlogo" style="width: 250px; margin: 0; padding: 0; border: 1px solid #ccc; background: #555; color: #fff; font-size: 09px; line-height: 12px; font-family: Verdana,Arial,Helvetica,Sans-serif; font-weight: bold;" title="Click here for more Energy news from NewsNow">
<div style="margin: 0; padding: 0; border: 1px solid #fff; background: #555;">
<div style="margin: 0; padding: 0; border: 0; width: 150px; height: 50px; float: left;"><img style="margin: 0px; display: block; border-width: 0px; padding: 0px;" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2012/05/News-Now.jpg" alt="As featured on NewsNow: Energy news" width="129" height="41" /></div>
<div style="padding: 0; border: 0; margin: 0 0 0 140px; text-align: center;"><span style="margin: 0; padding: 0; border: 0; display: inline-block; vertical-align: middle; text-align: center; width: 105px;"><a id="newsnowlogo_a" style="color: #fff; text-decoration: underline;" href="http://www.newsnow.co.uk/h/Industry+Sectors/Energy" target="_blank" rel="nofollow noopener">Energy</a> News 24/7</span></div>
</div>
</div>
</div></div><div id="text-25" class="widget widget_text col-md-3"><div class="widget-title"><h3>About Hydrogen Fuel News</h3></div> <div class="textwidget"><p>Hydrogen companies are growing faster than ever and we’re here to deliver the very best renewable energy updates within the market. Now available, news videos in English, French, German and Chinese. Our goal is to reach readers all over the world with fuel cell news science, green hydrogen alternatives and research reports – Let us know about hydrogen news in your area in our <a href="https://www.hydrogenfuelnews.com/submit-press-release/" target="_blank" rel="nofollow noopener">alternative energy press release</a> page and don’t miss today’s latest <a href="https://www.hydrogenfuelnews.com/alternative-energy-jobs/" target="_blank" rel="nofollow noopener">renewable energy jobs</a> listed. Thank you for picking HFN news today!</p>
</div>
</div> </div>
</div>
<footer id="colophon" class="footer-credits container-fluid">
<div class="container">
<div class="footer-credits-text text-center">
Proudly powered by <a href="https://wordpress.org/">WordPress</a> <span class="sep"> | </span>
Theme: <a href="https://envothemes.com/">Envo Magazine</a> </div>
</div>
</footer>
<div style="display: none;"><div id="boxzilla-box-53294-content"><p style="text-align: left;"><img class="alignright size-full wp-image-53686" src="https://www.hydrogenfuelnews.com/wp-content/uploads/2022/06/hydrogen-news-375-×-400-px.jpg" alt="hydrogen news" width="375" height="400" /></p><div class="AW-Form-1838391877"></div>
<script type="text/javascript">(function(d,s,id) {
                    var js;
                    var fjs = d.getElementsByTagName(s)[0];
                    if (d.getElementById(id)) return; js = d.createElement(s);
                    js.id = id; js.src = "https://forms.aweber.com/form/77/1838391877.js";
                    fjs.parentNode.insertBefore(js, fjs);
                    }(document, "script", "aweber-wjs-1430293065"));
                </script><p></p>
</div></div><script type="text/javascript" src="//www.hydrogenfuelnews.com/wp-content/themes/envo-magazine/js/bootstrap.min.js?ver=3.3.7" id="bootstrap-js"></script>
<script type="text/javascript" src="//www.hydrogenfuelnews.com/wp-content/themes/envo-magazine/js/customscript.js?ver=1.3.12" id="envo-magazine-theme-js-js"></script>
<script type="text/javascript" id="boxzilla-js-extra">
/* <![CDATA[ */
var boxzilla_options = {"testMode":"","boxes":[{"id":53294,"icon":"&times;","content":"","css":{"background_color":"#ffffff","width":375,"border_color":"#5bd604","border_width":10,"border_style":"double","position":"center"},"trigger":{"method":"percentage","value":10},"animation":"slide","cookie":{"triggered":24,"dismissed":5},"rehide":false,"position":"center","screenWidthCondition":null,"closable":true,"post":{"id":53294,"title":"newsletter","slug":"newsletter"}}]};
/* ]]> */
</script>
<script type="text/javascript" src="//www.hydrogenfuelnews.com/wp-content/plugins/boxzilla/assets/js/script.min.js?ver=3.2.25" id="boxzilla-js"></script>
<script defer="" type="text/javascript" src="//www.hydrogenfuelnews.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1664475391" id="akismet-frontend-js"></script>

<script async="" src="https://www.hydrogenfuelnews.com/wp-content/plugins/aweber-web-form-widget/php/../src/js/aweber-wpn-script.js"></script>
<script type="text/javascript">
            var aweber_wpn_vars = {
                plugin_base_path: 'https://www.hydrogenfuelnews.com/wp-content/plugins/aweber-web-form-widget/php/',
                register_aweber_service_worker: '',
            };
        </script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script type="text/javascript" data-cfasync="false"></script>
<script>var _audins_dom="hydrogenfuelnews_com",_audins_did=278980;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.hydrogenfuelnews_com,DomainId.278980" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=2&cb=4', false, [], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/tortoise.js', '/beardeddragon/tortoise.js?gcb=2&cb=4', false, [], true, false, true, false);</script>
<script>let ezVideoIframe=false;function renderEzoicVideoContent(){let videoObjects=[{"PlayerId":"ez-3","VideoContentId":"9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2","VideoPlaylistSelectionId":0,"VideoPlaylistId":0,"VideoTitle":"Hydrogen tech developer to build fastest electrocatalyst discovery process","VideoDescription":"[Hydrogen News](https://www.hydrogenfuelnews.com) H2U Technologies closed $11 million in Series A funding and will use the proceeds to achieve its goal...\n\nJericho Energy Ventures videos: \nhttps://www.youtube.com/watch?v=IxQRMLQXhxQ\nhttps://www.youtube.com/watch?v=iBo9FrxxPF4\n\nLearn more about green hydrogen: https://www.hydrogenfuelnews.com/what-is-green-hydrogen/\nGrab our free hydrogen ebook here: https://www.hydrogenfuelnews.com/hydrogen-fuel-cell-ebook/\n\n#H2UTechnologies #JerichoEnergyVentures #H2UTechnologiesCDE #Caltech #FreeflowVentures #greenhydrogen #greenhydrogentechnology #H2U #H2Uhydrogentechnologies #H2Uhydrogentechnologydevelopment #HessCorporation  #proprietaryhydrogentechnology #VoLoEarthVentures","VideoLinksSrc":"https://streaming.ezoic.com/link/9e0574c5ec0e6bed115382cbdba2f342616fea49777d93e4c533f5ed7ce6e1b2.vtt","Captions":null,"VideoDurationMs":147580,"DeviceTypeFlag":0,"FloatFlag":1,"FloatOptionFlag":1,"IsAutoPlay":true,"IsLoop":false,"ShouldConsiderDocVisibility":false,"ShouldPauseAds":false,"AdUnit":"","ImpressionId":0,"VideoStartTime":0,"IsStartTimeEnabled":0,"IsKeyMoment":false,"PublisherVideoContentShare":{"DomainIdOwner":278980,"DomainIdShare":278980,"IsEzoicOwnedVideo":false},"VAbTest":"vmod1-c","VAbTestVal":"","VideoPlaylist":null,"VideoPlaceholderId":3,"URL":"https://www.hydrogenfuelnews.com/hydrogen-boiler-jericho/8555584/","Width":654,"MaxWidth":"","Height":360,"PreviewURL":"","VideoDisplayType":1,"MatchOption":0,"PlaceholderSelectionId":0,"HashValue":"","IsFloating":true,"AdsEnabled":0,"IsAutoSelect":true,"Keyword":"","VideoSelection":2,"VideoMatchScore":76,"VideoPlaceholderHash":"","IsAIPlaceholder":false}];if(typeof ezVideoPlayer==="undefined"){__ez.queue.addFile("/beardeddragon/wyvern.js",'/beardeddragon/wyvern.js?cb=45',true,[],false,true,true,false);__ez.queue.addFile("/beardeddragon/gilamonster.js",'/beardeddragon/gilamonster.js?cb=110',true,["/beardeddragon/wyvern.js"],false,true,true,false);__ez.queue.addFile("/beardeddragon/gecko.js",'/beardeddragon/gecko.js?cb=30',true,[],false,true,true,false);__ez.queue.addFile("/beardeddragon/iguana.js",'/beardeddragon/iguana.js?cb=121',true,["/beardeddragon/wyvern.js","/beardeddragon/gecko.js"],false,true,true,false);__ez.queue.addFunc("ezoicVideoNonCmb","renderEzoicVideoContent",null,false,["/beardeddragon/iguana.js"],false,false,true,false);return;}
window.ezIntType="";for(vIndex=0;vIndex<videoObjects.length;vIndex++){let videoObject=videoObjects[vIndex];videoObject.videoObjectsCount=videoObjects.length;videoObject.videoObjectsIndex=vIndex+1;ezVideoPlayer.Init(videoObject);}}
__ez.queue.addFile("/beardeddragon/wyvern.js",'/beardeddragon/wyvern.js?cb=45',true,[],false,true,true,false);__ez.queue.addFile("/beardeddragon/gilamonster.js",'/beardeddragon/gilamonster.js?cb=110',true,["/beardeddragon/wyvern.js","/porpoiseant/jellyfish.webp"],false,true,true,false);__ez.queue.addFile("/beardeddragon/iguana.js",'/beardeddragon/iguana.js?cb=121',true,["/beardeddragon/gilamonster.js","/beardeddragon/gilamonster.js"],false,true,true,false);__ez.queue.addFunc("ezoicVideo","renderEzoicVideoContent",null,false,["/beardeddragon/iguana.js"],false,false,true,false);</script></body></html>